I am finally done with lesson one. I can tell already that the lessons are too long for the brief periods of time I have available to work on them, at least this past week. It has been somewhat frustrating because of that. I need to set aside bigger chunks of time. I wish that I were only paying for when I am actively using Udacity, instead of the clock running all of the time whether I am online using the web site or offline doing something else.
The lesson was not too frustrating until the end where things got really confusing between when they were using TextViews and when they were using ListViews. It would also help matters a great deal if they would spell out what variable names to use instead of me having to go back to my code and say, “Oh, I called that a widget when they called that a whatsit.” Most of the time, our variable names are in sync because we are both using logical names, but sometimes the good-name space is just too large.
And I am fairly certain that “listview_forecast” was originally “list_item_forecast” in an earlier video. “listview_forecast” is the better name, but only if you actually assigned it to the ListView earlier instead of “list_item_forecast”! On the positive side, I can tell that developer.android.com is going to be my new best friend, along with the excellent book on Android development that I just purchased.